Cisco для новичков. Часть 1.Первоначальная настройка маршрутизатора Cisco

Начинаем курс статей под кодовым названием Cisco для новичков

Собственно сабжект говорит о том что я постараюсь описать в данной статье…

Имеем Cisco 2911… поехали

начну с того, что на 18XX 28XX и почих маршрутизаторах 8 серии подключение и первоначальная настройка оборудования осуществляется через консольный порт с разъемом RJ-45, обычно, кабель для настройки идет в комплекте, представляет из себя RJ-45 на RS-232 голубого цвета. Оборудование 19XX 29XX серий помимо консольного порта RJ 45  имеет консольный порт MiniUSB (Что значительно удобнее при настройке оборудования имея под рукой ноутбук с отсутствующим COM портом). Для настройки оборудования через MiniUSB нам понадобится драйвер эмуляции
Далее в Device Manager появится Cisco Serial где можно настроить номер порта.

Установка соединения осуществляется со стандартными значениями – 9600 бод/8 бит данных/1 стоп бит/без проверки четности и контроля прохождения. В Windows – системах вы можете использовать putty,  в Linux  cu или minicom. В дальнейшем, когда маршрутизатору будет присвоен IP-адрес для настроек будем использовать ssh, но первый раз без консольного подключения не обойтись.

Открываем Putty, выбираем тип подключения Serial порт COM7 ( У меня он COM7) нажимаем 2 раза [Enter] и видим меред собой командную строку с приглашением роутера

Router>
Переходим в превелегированный режим командой enable
Router>enable
Router#
удаляем имеющуюся конфигурацию, находящуюся во флэш-памяти, и перезагружаем маршрутизатор:
Router#erase startup-config
Router#reload
Ждем пока роутер перезагрузится, наблюдая за процессом загрузки в окне консоли, после чего снова переходим в превилигированный режим
Router>enable

Переходим в конфигурационный режим и даем команду hostname:
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Gw0
Gw0(config)#
Включим режим хранения паролей в файле конфигурации устройства в зашифрованном виде:
Gw0(config)#service password-encryption
Отключим управление маршрутизатором через http и https и CDP
Gw0(config)#no ip http server
Gw0(config)#no ip http secure-server
Gw0(config)#no cdp run
Зададим пароли на подключения через консольный порт
Gw0(config)#line con 0
Gw0(config-line)#password пароль
Gw0(config-line)#login
Gw0(config-line)#exit
И Telnet
Gw0(config)#line vty ? О, сколько он там сказал доступно? 0-1441 значит line vty 0 1441 ))
Gw0(config-line)#password пароль
Gw0(config-line)#login
Gw0(config-line)#exit
Зададим пароль на Enable режим
Gw0(config) enable secret пароль_enable_режима

Перейдем к настройке интерфейса внутренней сети. Если маршрутизатор имеет гигабитные порты то названия портов можно сократить как Gi 0/0 (Gigabit ethernet) , если 100 Мбитные то скорее всего это будут Fa (fast ethernet)
В принципе, если вы сомневаетесь в команде, нажмите TAB — в командной строке команда дописалась? значит норма, не помните что вводить? введите знак вопроса… IOS выдаст вам все доступные команды в данном контексте.
Gw0(config) #interface Gi 0/0
Gw0(config-if)#ip address 192.168.0.1 255.255.255.0
Gw0(config-if)#description LAN
Gw0(config-if)#no shutdown
Gw0(config-if)#exit
Задаем dns-сервера

Gw0(config)# ip name-server 192.168.0.2

Все, маршрутизатор доступен телнетом по 192.168.0.1
Записываем конфигурацию в память командой
Gw0# copy running-config startup config или командой wr

В следующей статье,собственно, мы отключим доступ на маршрутизатор через telnet (Ибо не секюрно ) и настроим доступ к нему используя SSH.

To be contined

Статья помогла? поддержите проект!

Cisco для новичков. Часть 1.Первоначальная настройка маршрутизатора Cisco: 20 комментариев

  1. Уведомление: Часть 2.Первоначальная настройка маршрутизатора Cisco. Telnet или SSH |

  2. Алексей

    Помогите моей беде!!!!!
    Cisco 892
    после записи конфигурации в память командой
    Gw0# copy running-config startup config он пишет
    Building configuration [OK]
    и дальнейшей перезагрузке командой reload девайс возвращается в стартовое положение, ничего не запоминает: паролей нет, имен нет при загрузке по прежнему предлагает войти в меню автоматической конфигурации. Что делать не знаю но признаюсь что нажал кнопку reset на задней панели. что сейчас можно сделать?????
    Заранее спасибо.

      1. Алексей

        может еще подскажите?!
        Cisco 892 на FastEthernet IPшник приципить нельзя ибо пишет
        IP addresses may not be configured on L2 links
        Назначаю IP на vLan или на GigabitEthernet но ни телнетом ни SSH приципиться не могу, хотя они разрешены, и даже не пингуются, как подключиться к девайсу через сеть???

        1. admin Автор записи

          Router>enable
          Router#configure terminal
          Router(config)#interface vlan 10
          Router(config-if)#ip address 192.168.0.1 255.255.255.0
          Router(config-if)#no shutdown
          Router(config-if)#exit
          Router(config)#interface Ethernet0
          Router(config-if)#switchport mode access
          Router(config-if)#switchport access vlan 10
          Router(config-if)#no shutdown
          Router(config-if)#exit

  3. Иван

    Добрый день. Прошу помочь. Изначально получил настроенный роутер и теперь сам пытаюсь разобраться и внести корректировки. Была поставлена задача заблокировать smtp порт (кроме 192.168.1.221) для отправки из внутр.сети и запретить доступ к внешним фтп серверам для адреса 192.168.1.150. Создал Acl withoutspam(применил его к внутреннему интерфейсу vlan 1). С сервером ftp как соединялся так и соединяюсь.(такое ощущение что acl не работает, тоже самое с почтой). На роутере настроен впн туннель с др.организацией (ip address **.**.193.236).

    CISCO891-K9
    !
    crypto isakmp policy 10
    encr aes 256
    authentication pre-share
    group 2
    lifetime 28800
    crypto isakmp key ****** address **.**.193.236
    !
    crypto ipsec transform-set UA esp-aes 256 esp-sha-hmac
    !
    crypto map IPSEC 10 ipsec-isakmp
    set peer **.**.193.236
    set transform-set UA
    set pfs group2
    match address CRYPTO
    !
    interface FastEthernet8
    no ip address
    duplex auto
    speed auto
    !
    interface GigabitEthernet0
    ip address **.***.123.121 255.255.255.0
    ip flow egress
    ip nat outside
    ip virtual-reassembly in
    duplex auto
    speed auto
    crypto map IPSEC
    !
    interface Vlan1
    ip address 192.168.1.200 255.255.255.0
    ip access-group withoutspam in
    ip flow ingress
    ip flow egress
    ip nat inside
    ip virtual-reassembly in
    !
    ip forward-protocol nd
    !
    ip flow-export destination 192.168.1.11 2055
    ip flow-top-talkers
    top 30
    sort-by bytes
    cache-timeout 30000
    !
    ip http server
    ip http authentication local
    ip http secure-server
    ip nat inside source list NAT interface GigabitEthernet0 overload
    ip route 0.0.0.0 0.0.0.0 **.***.123.1
    !
    ip access-list extended CRYPTO
    permit ip 192.168.1.0 0.0.0.255 192.168.2.0 0.0.0.255
    ip access-list extended NAT
    deny ip 192.168.1.0 0.0.0.255 192.168.2.0 0.0.0.255
    permit ip 192.168.1.0 0.0.0.255 any
    ***************************************************
    ip access-list extended withoutspam
    remark CCP_ACL Category=17
    permit tcp host 192.168.1.221 eq smtp any eq smtp
    deny tcp any eq smtp any eq smtp
    deny tcp host 192.168.1.150 eq ftp any eq ftp
    permit ip 192.168.1.0 0.0.0.255 any
    permit ip 192.168.2.0 0.0.0.255 any

    ***************************************************
    !
    access-list 1 remark CCP_ACL Category=2
    access-list 1 permit 192.168.1.0 0.0.0.255
    access-list 99 permit **.61.32.130
    access-list 99 permit **.86.62.248
    access-list 99 permit 192.168.1.0 0.0.0.255
    !
    route-map noNAT permit 10
    match ip address NAT
    !
    control-plane
    !
    mgcp profile default
    !
    !
    line con 0
    line 1
    modem InOut
    stopbits 1
    speed 115200
    flowcontrol hardware
    line aux 0
    line vty 0 4
    access-class 99 in
    exec-timeout 20 0
    password 7 ***********
    logging synchronous
    login local
    transport input telnet ssh
    line vty 5 15
    access-class 99 in
    exec-timeout 20 0
    logging synchronous
    login local
    transport input telnet ssh
    !
    end

  4. admin Автор записи

    В вашем случае должен нормально отработать следующий ACL

    ip access-list extended withoutspam
    permit tcp host 192.168.1.221 any eq smtp
    deny tcp host 192.168.1.150 any eq ftp
    deny tcp any any eq smtp
    permit ip 192.168.1.0 0.0.0.255 any
    permit ip 192.168.2.0 0.0.0.255 any

    int vlan1
    ip access-group withoutspam in

  5. Алексей

    Доброго дня!
    После выполнения на 9211r комманд
    Router#erase startup-config
    Router#reload
    Пытаюсь зайти на свитч и логин по умолчанию cisco пароль cisco — не работает пишет
    % Login invalid
    =) Впервые настраиваю циску, помогите пожалуйста!

  6. Алексей

    Тут товарищ купил Cisco 2901, думал что настроит так же как dir300, не получилось простит меня, у хоть и пользователь не первого года, и с теленетом дружил, хоть и очень давно, но все равно для меня много не понятного. Кто-то может удаленно через teamviewer настроить за денежку конечно, нужно настроить подключение PPPOE, чтобы осуществлялась раздача инета по сети. Пишите мне на ***@bk.ru, я состыкую.

  7. Владимир

    Добрый вечер

    Есть cisco 5505
    Задача подключить провайдера и раздать dhcp
    1) Провайдер получаем по dhcp wan
    2)DHCP на порты 1-5
    3) 3 порт на телевидение
    2) 2 порт на wi-fi

  8. Сергей

    доброго дня. Спасибо за статью. Я новичок, пытался все повторить в cisco packet tracer на cisco 2811. Из написанного Вами там команды:
    Gw0(config)#no ip http server
    Gw0(config)#no ip http secure-server
    и
    Gw0# copy running-config startup-config
    не работают

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Time limit is exhausted. Please reload the CAPTCHA.